A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2026 - 20:41 CET
Identified
We’re currently experiencing intermittent issues due to degraded performance at our external DNS provider. This may cause slow DNS resolution and delayed or failed requests for some users.
Posted Feb 10, 2026 - 19:16 CET
This incident affected: Portal and Main Platform, Checkout & Self Service Center, API, and Developer Docs.