Mollie API disruption
Incident Report for Firmhouse
Resolved
This incident has been resolved.
Posted Feb 19, 2024 - 17:05 CET
Update
We are continuing to monitor for any further issues.
Posted Feb 19, 2024 - 16:49 CET
Monitoring
The Mollie API is having technical difficulties causing some checkouts for merchants using Mollie as payment service provider to not get through. We're monitoring the situation as Mollie is working on a solution: https://status.mollie.com/incidents/7csjtq8vvj63
Posted Feb 19, 2024 - 16:36 CET
This incident affected: Checkout & Self Service Center and API.