The issue is now resolved. We've implemented measures to prevent this from happening again in the future.
Posted Sep 09, 2025 - 18:18 CEST
Monitoring
A solution has been implemented, and our processing has successfully caught up with the backlog.
Posted Sep 09, 2025 - 17:54 CEST
Identified
We have observed that certain processes are taking longer than expected. We have identified the underlying issue and are actively working on a resolution.
Posted Sep 09, 2025 - 17:38 CEST
This incident affected: Portal and Main Platform and Checkout & Self Service Center.