Email sending delayed
Incident Report for Firmhouse
Resolved
Problems with sending emails have been resolved! Sorry for the trouble.
Posted Jun 22, 2023 - 22:02 CEST
Identified
Our email provider is experiencing downtime which is why email sending is delayed. Klaviyo and custom SMTP setups are not impacted.
Posted Jun 22, 2023 - 20:33 CEST
This incident affected: Portal and Main Platform.