API disruption at Mollie

Incident Report for Firmhouse

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 11:14 CET

Monitoring

Mollie has reported that they have implemented a fix to address the API disruption and are currently monitoring the results.
Posted Jan 21, 2026 - 11:00 CET

Identified

We are experiencing a significant disruption affecting checkouts and payment processing for all merchants using Mollie.

Mollie has confirmed a Full Disruption of their API. As a result, API calls are currently failing or timing out, which prevents payments from being initiated or completed successfully.

Our team is monitoring Mollie's progress closely. You can also follow their official incident report directly for real-time updates: https://status.mollie.com/cmknu65c00alxlh6zc1una9yz
Posted Jan 21, 2026 - 10:51 CET
This incident affected: Checkout & Self Service Center.