Partially delayed billing cycle delayed
Incident Report for Firmhouse
Resolved
This morning at around 10:00 CET, we successfully processed the remaining billing cycle for the subset of merchants that were affected by the delay last night.
Posted Jan 05, 2024 - 13:09 CET
Identified
We have noticed a delay in processing this night's billing cycle for a subset of merchants. Our team is working on a fix.
Posted Jan 05, 2024 - 08:59 CET
This incident affected: Portal and Main Platform.