User interface issues on Checkout
Incident Report for Firmhouse
Resolved
This incident has been resolved.
Posted Oct 16, 2023 - 13:41 CEST
Update
We are continuing to monitor for any further issues.
Posted Oct 16, 2023 - 12:29 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2023 - 12:29 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2023 - 12:20 CEST
Investigating
We are investigating an issue where UI elements on Firmhouse Checkout aren't displaying correctly
Posted Oct 16, 2023 - 12:12 CEST
This incident affected: Checkout & Self Service Center.