Degraded performance on report generation
Incident Report for Firmhouse
Resolved
The issue has been resolved. In some cases the degraded performance caused reports to get stuck, if this is the case for you, please try again. Apologies for the inconvenience.
Posted Mar 19, 2024 - 16:36 CET
Identified
We are seeing some performance issues that will cause report generation through our portal to take longer than usual. We're currently working on a solution.
Posted Mar 19, 2024 - 11:02 CET
This incident affected: Portal and Main Platform.