Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2025 - 02:00 CEST
Scheduled
We’re scheduling a series of upgrades to our database infrastructure to improve reliability, speed, and scalability of our platforms. These changes will help us deliver faster responses, increased resilience, and better performance under peak loads.
To safely apply these improvements, we will perform maintenance in three short windows over the coming weeks. Each window may involve brief service interruptions of up to a few minutes.
We will monitor the platform closely throughout and after each window. If you notice any issues beyond the announced times, please contact support.
Thank you for your understanding.
Posted Sep 12, 2025 - 16:07 CEST
This scheduled maintenance affected: Portal and Main Platform, Checkout & Self Service Center, API, and Firmhouse Data Platform.